前一阵子项目用到了SocketRocket和白鹭游戏引擎。

SocketRocket.framework/SocketRocket' does not have proper segment alignment.

具体的问题可以参考此链接

我的解决方案是把白鹭中的SocketRocket移除,然后是用CocoaPods来集成,但是发现白鹭使用的不也是SocketRocket最新的Release版,于是,

pod ‘SocketRocket’, :git => ‘https://github.com/facebook/SocketRocket’, :commit => ‘28035e1’

这样就能拿到最新的git版本库代码。

pod install

大吉大利